AMD终于在Linux 5.16版本中为较新的硬件默认启用了PSR

随着Linux5.15内核即将完工,直接渲染驱动程序维护者的工作重点正在从针对下一周期(5.16)的新功能工作转移到错误修复上。AMD本周发出了一份AMDGPULinux5.16素材的拉动请求,主要是提供错误修复,但一个值得注意的补充是最终为较新的GPU默认启用PSR。在前几

NetSmell 出品

  随着 Linux 5.15 内核即将完工,直接渲染驱动程序维护者的工作重点正在从针对下一周期(5.16)的新功能工作转移到错误修复上。AMD 本周发出了一份 AMDGPU Linux 5.16 素材的拉动请求,主要是提供错误修复,但一个值得注意的补充是最终为较新的 GPU 默认启用 PSR。

  在前几周,AMDGPU 向 DRM-Next 提出的 Linux 5.16 拉动请求带来了 DisplayPort 2.0 首次启用、Cyan Skillfish 显示支持、USB4 DisplayPort 隧道和其他变化。

  本周为 5.16 合并窗口向 DRM-Next 提出的拉动请求包括围绕 Cyan Skillfish Navi 1x APU 支持的更多修复,IP 发现枚举修复,显示器问题修复,Aldebaran 的 RAS 修复,Raven Ridge 的 IOMMU 修复,以及其他修复。

  这个拉动请求中隐藏的一个补丁带来了一些令人兴奋的地方,即在较新的 DCN 硬件上默认启用 PSR。是的,面板自我刷新终于在较新的硬件上被默认启用。尽管在这个时候,较新的硬件所支持的是带有 DCN 3.1 的 Yellow Carp(Rembrandt)。带有 DCN-3.1 之前的硬件的 GPU 目前保持 PSR 关闭。

  面板自刷新是一项省电功能,当显示屏/显示器内容是静态的时候,能够关闭额外的电路。虽然 PSR 是一个行业标准,但对于英特尔硬件和各种笔记本显示面板来说,它也被证明是古怪的。由于一些桌面合成器不能正确地翻页和扫描出与他们的 PSR 处理方式有关的问题,AMD 将他们的 PSR 支持被禁用到现在。现在,AMD 更好地处理了合成器,因此认为默认情况下启用面板自刷新是安全的。但由于可能出现错误/退步,至少现在 AMD 没有为现有硬件启用 PSR,只是为 DCN 3.1 和更新的显示硬件默认设置。

  我们将在一段时间后看到他们是否决定为现有的 AMD 硬件打开 PSR。

  这个最新的 AMDGPU/AMDKFD 拉动请求到 DRM-Next 的补丁列表可以在这里找到:

  https://lists.freedesktop.org/archives/amd-gfx/2021-October/070204.html

显示余下内容
 

发表评论

邮箱地址不会被公开。 必填项已用*标注